Building for Android

So I'm at the point where I want to build my project for android. I get to where it shows Keystore setting. I am not sure how to create one through here. I have done it before for android studio but for this I am lost. I looked through the docs and I am not seeing anything about publishing to android.
Has invited:

lijh

Favor from:

You can create a keystore file through ADT.
FYR: http://developer.android.com/t ... .html

valdeezzee

Favor from:

Ok so I created a keystore file and when I went to publish I hit build and it stays stuck. Any idea why? been like that for 10 mins now.

valdeezzee

Favor from:

I click on the jks file and then after I hit create, it gives me this error. I don't know what I am doing wrong.

lijh

Favor from:

It looks like you havn't configured the JDK path in preference panel.
jdk-3.png

jdk-4.png


 
 

lijh

Favor from:

And we will fix this issue and move the Android Environment controls from preference panel to publish panel in the next version.

winterstar

Favor from:

I've encountered the same problem. I already set up JDK path as suggested above.
Tried both "use existing keystore" and "create new keystore" options, they both gave me an error "The keystore path is error" with msg in weird characters "郎嘿ヘ魁嘿┪合盒跋夹乓粂猭岿粇"
any suggestions?

kylinchen

Favor from:

The keystore path value needs to include the file name。
Like:
c:/myApp/mykey.keystore

winterstar

Favor from:

Thanks for the suggestion. I did put in the file name.
Here is what I did,
In preference, I set JDK path to "C://Program Files//Java//jdk1.8.0_77//bin"

I used the following command to generate keystore file
keytool -genkey -v -keystore my.keystore -alias rdss -keyalg RSA -keysize 2048 -validity 10000

and in QICI, I choose "Use Existing KeyStore", point to the keystore file, "C://Work//Projects//QICI//my.keystore" 
anything wrong with my settings?

kylinchen

Favor from:

The error message "The keystore path is error" is throwed by "tool/editorService/module/Project.js" when the keystore file isn't exists or is a directory。You can use  "G.log.trace('The keystore file path is :' + filePath);" to print the file path to console. 
And in order to fix weird characters message, try change ''process.platform === 'win32' ? 'gbk' : 'utf8';" to your local encoding. 

winterstar

Favor from:

Thanks a lot for the help.
I used G.log.trace, it did print out correct path "C://Work//Projects//QICI//my.keystore"
and changed to local encoding (traditional chinese), the error message says "File name, directory name, or drive label error"
Any idea how to fix? Really appreciated.

kylinchen

Favor from:

Try copy the keystore file to other path, or use 'c:/work/Projects/QICI/my.keystore'.

winterstar

Favor from:

Updates: Need to set Android environment (paths to JDK/NDK/SDK)
Now, I got this error msg - C:\Work\Projects\QICI\Test\Build\android\PublishProject\ver20160510011410\app\build\intermediates\manifests\full\release\AndroidManifest.xml:2 : AAPT: Tag <m
anifest> attribute package has invalid type 16.
 
Any suggestions? Sorry, not much experiences with Android build
 

lijh

Favor from:

It seems there's something wrong with the package attribute in AndroidManifest.xml, the package attribute comes from the 'Bundle Id' property in publish panel of QICI, you can check it first.
 
If still unable to resolve this issue, you can upload the AndroidManifest.xml file for more help.

winterstar

Favor from:

Problem solved. In case someone ran into the same problem.
When you publish Android build, make sure Bundle ID is the same as Local Storage ID in Project Settings.

lijh

Favor from:

It's not necessary to set BundleID the same as LocalStorageID, what's you previous BundleID?

winterstar

Favor from:

just some random ID I created. like com.work.game
 

To reply to a question, please Login or registered